WorkRite experiencing connectivity issues
Incident Report for Q-Pulse WorkRite
Resolved
The issue is now resolved. We're sorry for any impact this has had.
Posted Feb 20, 2018 - 22:23 GMT
Investigating
We're currently experiencing some problems with the WorkRite platform. We are currently working with Microsoft to investigate the issue.
Posted Feb 20, 2018 - 20:50 GMT