Email service delay
Incident Report for Q-Pulse WorkRite
Resolved
The email service is now operating normally. Thanks for your patience.
Posted Feb 26, 2019 - 15:28 GMT
Monitoring
There is currently a delay in emails being processed. We are monitoring the situation and expect to be back to normal operation by the end of the day (Tuesday 26th Feb).
Posted Feb 26, 2019 - 11:44 GMT
This incident affected: Email.